SocialKit requires atleast PHP version 5.4.0 to work. Your PHP version is: 5.3.29. PHP 5.4.0 was released on March 2012. It's about time you make the upgrade. Please upgrade your PHP version to 5.4+ or contact your hosting provider and ask them to upgrade it to 5.4+.